Control Panel and Menus


Section Controls
Contrast Controls
Display Controls
Transformation Controls
File Menu Items
Edit Menu Items
Controls when Fixing Montages

Section Controls

Reference Sec. and Current Sec.
The two spin boxes show the section numbers (numbered from 1) of the reference and current sections. The section can be changed as desired by typing a number in one of the text boxes or by pressing the up or down arrow buttons.
Keep Cur - Ref diff = 1
If the Keep Cur - Ref diff = 1 check box is selected, both reference and current sections will be changed in tandem. (This control is not present when aligning chunks.)
Current Chunk
When aligning chunks of sections, there is another spin box for selecting the current chunk. Alignment is always between successive chunks. If the chunks are specified with the number of slices in each chunk (the -c option), the current section is constrained to stay within the current chunk and the reference section is constrained to stay within the previous chunk. If the chunks are specified by the number of slices in each sample from a chunk (the -cs option), the selected section is constrained to stay within its respective sample. When a pair of chunks is first selected, the lowest section of the current chunk and the highest section of the previous chunk will be displayed.

Contrast Controls

Black and White sliders
The Black and White sliders control the intensity range that will be scaled to run from black to white on the screen. Ordinarily, the program will update the display continuously while a slider is dragged. If the update is too slow, you can press the [Ctrl] key to make the display update only when the mouse button is released, just as in 3dmod.
Apply to only one sec.
Each section has its own independent contrast setting. If the Apply to only one sec. check box is not selected, then changing the contrast (via the sliders or F1-F8 keys) will adjust the contrast for all sections in parallel. If this check box is selected, then changes will adjust the contrast for just one section, the one currently being displayed (or the current section, if the display shows both sections in overlay.)
Auto Contrast
The Auto Contrast button will adjust the contrast based on the mean and standard deviation of the currently displayed section (or the current section, if the display shows an overlay). The contrast setting is the same as the default for auto contrast setting in 3dmod.

Display Controls

Zoom
The Up and Down Arrows for Zoom increase and decrease the zoom of the display. Fractional zooms are possible, and needed for large images.
Interpolate
The Interpolate check box can be used to turn on bilinear interpolation in the image transformation, which will give the most accurate transformed image of the current section but may be slow for large images.
Overlay view
The Overlay view box can be used to toggle between showing one section and showing the two sections in overlay, with the current section in green and the previous in magenta.
Toggle Ref/Cur
The Toggle Ref/Cur button provides an easy way to toggle between current and reference sections with a mouse button.

Transformation Controls

At the top of this section are three lines listing the actions of the left, middle, and right mouse buttons. The second line shows the actions when the Ctrl key is pressed, the third shows actions when the Shift key is pressed, and the first shows actions when neither is pressed. The currently active line will appear in red, and it will change to indicate the current action when a mouse button is pressed.

The Add/edit warp points check box can be used to warp the image, using local shifts at a set of points called control points. Once this is turned on, the only transformation parameter that can be changed is the shift of the current control point. See the Warping Images section of the man page for a description of using warping.

The Arrow buttons allow each transformation parameter to be changed by a selected increment. There is an additive increment for translation, an independent increment for rotation angle, and a multiplicative factor for magnification and stretching.

The Stretch Angle slider sets the axis along which the section will be stretched by either an Arrow button or a hotkey. This axis is shown by the red dashed line. If the section has already been stretched, the axis of that actual stretch is shown with a blue dashed line.

Rotation, magnification, and stretch will occur around the center of rotation, which is marked by the yellow star. You can use [Ctrl]+Middle-Mouse-Button to move this center to a point that you want to keep fixed during further changes of the transformation. You can also set up a second fixed point using [Ctrl]+Right-Mouse-Button, after which stretching with the mouse will keep both the center and this fixed point at constant positions.

Correcting image stretch can be nonintuitive when done just with a regular stretch. Here is a procedure to follow using stretching with a second fixed point:

  1. Translate to align the images at some location.
  2. Move the center point to that location.
  3. Rotate and stretch to align the images at a second, distant location.
  4. Set a second fixed point at that location.
  5. Stretch with the right mouse button to align the images in other places.
  6. If the images are still not aligned well enough, pick a new center point and second fixed point at two well-separated places where they now seem best aligned, and stretch again.

The same thing can be accomplished in a similar way by adding only 3 warping points, which still leaves just a linear transformation.

  1. Translate to align the images at some location.
  2. Turn on Add/edit warp points.
  3. Add one point at the aligned location.
  4. Add a second point at a second, distant location and shift to align the images there.
  5. Add a third point and shift it to give the best overall alignment with a stretch.

The Cross-Correlate button can be used to align the images by cross-correlating them in a square area around the center point marked with the yellow star. The program will search for peaks in the cross-correlation of padded and filtered extracts from the two images, then evaluate the correlation coefficient for peaks within a certain range of the origin and pick the peak with the highest correlation. The size of the region being correlated can be set in the Box spin box, and the limit on the shift in X and Y that can be found is adjusted with the Limit spin box. These shifts are incremental to the current translation between images, so if you adjust the translation approximately, the correlation should be able to find a small shift to refine your translation. The parameters for padding and filtering are based on the settings that are most successful in Blendmont when finding overlaps between adjacent pieces.

The extent of the area being correlated is shown temporarily when any of the related controls are used. The box is drawn in yellow when the size or shift limit is adjusted; it is drawn in green after a correlation that succeeds in giving a peak and in red when the correlation fails to yield a peak within the shift limit.

Below the cross-correlation controls are some buttons that become active when there are more than 3 warping points, and that may be useful when reading in a warping transformation computed by cross-correlation. The Biggest button will select the warping point that has the largest shift. The down and up arrows will move from the currently selected warping point to the one with the next lower or next higher shift. Turn on the Draw warp vectors checkbox to see a line representing the amount of shift at each warp point.

If the program was started with "-a" to specify a Global rotation angle, this angle is displayed and can be adjusted with the spin box below the Stretch Angle slider. Use the up and down arrows to adjust the angle by 1 degree, or type in a new value directly. Select Mouse shifts X only to constrain translation changes with the mouse to the X direction in the rotated images. With this constraint, it is still possible to change the shift in Y with the arrow hot keys or the Y translation arrow buttons.

If the program was started with "-t" and a file of tilt angles, then two more controls appear. Select Apply cosine stretch to stretch the current image along the X axis by the ratio of the cosines of the current and reference image tilt angles. They should be easier to line up with this stretching. Below this checkbox is the Tilt angle offset spin box to allow you to adjust the tilt angles by a constant amount. For very high tilt angles, this offset may be needed to get the right amount of cosine stretching.

File Menu Items

Edit Menu Items

Controls when Fixing Montages

X edges are between adjacent pieces in a row and are numbered from left to right in the bottom row, next row, etc. Y edges are between adjacent pieces in a column and are numbered from bottom to top in the left-most column, next column, etc. Every edge can also be identified by its lower piece, namely the piece to the left of an X edge and below a Y edge.

In the top panel, the X and Y radio buttons can be used to select which type of edge, if there is more than one type of edge in a section. The edge number is displayed in a spin box and can be changed by typing a new number into the text box or by pressing the up and down arrow buttons. In addition, the position within the montage of the lower piece of an edge is displayed in X and Y spin boxes; these piece positions are numbered from 1. These spin boxes provide a more convenient way to know where an edge is and navigate between edges, such as to see all of the edges around a particular piece.

The Exclude edge checkbox allows you to exclude an edge from further consideration both in Midas and in Blendmont. If you excluded edges with a model file when running Blendmont, it will already be marked as excluded here. When the next checkbox, Skip excluded edges, is on, the program will skip over excluded edges when you move between edges with the controls, and it will omit these edges from any error computations (see below). If you excluded any edges with a model, this option will be turned on by default; otherwise, you need to turn it on when you first exclude edges. Turn this option off to go to any of these edges in order to include them again and adjust their displacements.

Only X and Y translations of one piece relative to another can be changed when fixing montages.

Cross-correlation can be used when fixing edges; it may be more successful than the correlation within Blendmont because you can select the center of the area to correlate. The area correlated corresponds to the intersection of the region where the two pieces overlap and the square correlation box shown on the screen.

The bottom panel displays information about the errors in fitting pieces together with the current displacements and allows one to go to the edges with the highest error. An error is the difference (or distance) between the displacement between pieces implied by the X and Y translation values at that edge, and the displacement achieved when all pieces are shifted into best alignment using the translation values for all of the edges.

For the edges with the six highest errors, the edge number and error are displayed in a button, which can be pressed to make that edge be the current edge. The errors, and even the edges, displayed in these buttons will change whenever the displacement at the current edge is changed. You can select the number of buttons to display (between 2 and 10) with the "-e" option when starting the program.

Below the buttons are the X and Y components of the error at the current edge. On the line below that is the "Leave-out" error for the current edge, which is its error when its translation values are left out when solving for the best fit between pieces. This error can be compared directly with any mismatch observed between the pieces. Pressing the Apply Leave-out Error button will change the X and Y translations by these amounts.

When there are more than 10 pieces, the program can do robust fitting to eliminate outlying displacements from the estimation of piece shifts. This procedure is enabled with the Robust fits checkbox, which is on by default. It will accentuate the errors of the outliers when there are many pieces and make it easier to find these edges and either exclude them or fix their displacements. A spin box allows the criterion for outlier elimination to be adjusted. See the man page for more details.

When there are over 625 pieces, the errors are estimated using local patches of pieces in order to save time, so they may not exactly match the values in Blendmont. With many thousands of pieces, the error computation may noticeably slow down the program when moving between edges. There is a checkbox, Skip error computation, to avoid this delay when browsing through edges.