3dmodv(1)                                                            3dmodv(1)



NAME
       3dmodv - View an Imod model.

SYNOPSIS
       3dmodv  [options]  model_files...

DESCRIPTION
       3dmodv is used to view models drawn with 3dmod.  The main 3dmodv window
       is the same as the "Model View" window available in the program 3dmod.
       When run from the command line, 3dmodv can read and save models through
       the File menu.  Multiple models can be loaded and manipulated indepen-
       dently, either by putting their names on the command line or by loading
       them one after another through the File menu.  The command line options
       and hot keys are given below.  See the Help menu of the Model View win-
       dow for information on mouse actions and menu entries; see the help
       pages for individual dialogs for full details on the controls in each
       dialog.

OPTIONS
       3dmodv can accept standard Qt options in addition to the options
       described below.

       -f     Open model view window to maximum size supported by graphics.

       -b color
              Select the color that 3dmodv uses as the rendering background.
              The color is a standard Qt color name.

       -s width,height
              Set the initial size of the model view area of the window.  This
              is useful if you want to take snapshots at a specific size.

       -E keys
              Open the windows specified by the key letters, which are the
              same as the hot keys for opening windows (m, O, C, L, B, M, N,
              V, I, U, R), plus D for depth cue and S for stereo.

       -L     Listen for messages on standard input instead of the clipboard,
              and do not put 3dmodv in the background automatically.

       -D     Run in debug mode with diagnostic output and without becoming a
              background process.


   Hot key shortcuts for 3dmodv.
       - =    Decrease/increase zoom with small steps.

       Keypad +
              Increase zoom by small steps

       _ +    Decrease/increase zoom with large steps.

       1 2    Step back/forward in time.

       9 0    Step to previous/next model.

       8      Toggle displaying all models or one model.

       Arrow Keys, Page Up, Page Down
              Translate model, or current clipping plane if Ctrl is held down,
              in X, Y, and Z, or current point if Ctrl and Shift are held down
              and the current point is in a scattered point object.

       Ctrl-Shift-Delete
              Delete the current point if it is in a scattered point object
              and 3dmod is in model mode.

       Numeric Keypad
              Rotate model, or current clipping plane if Ctrl key is held
              down:
                 The 4 and 6 keys rotate about the Y view axis.
                 The 8 and 2 keys rotate about the X view axis.
                 The 9 and 3 keys rotate about the Z view axis.
                 The Enter Key toggles between movie and incremental motion.

       Substitute Keypad
              The keys centered on U will also rotate the model or clipping
              plane:
                 The y and i keys rotate about the Y view axis (but Ctrl-U
              instead of
                    Ctrl-Y rotates the clipping plane).
                 The 7 and j keys rotate about the X view axis.
                 The 6 and h keys rotate about the Z view axis.
                 The u key toggles between movie and incremental motion.


       t b l r f b
              Show top, bottom, left, right, front, or back face of model.

       , .    Decrease or increase the rotation increment and movie speed.


       Escape, q
              Quit 3dmodv or close model view window.

       B      Open dialog to set background color.

       C      Open the Control editing dialog.

       R      Open the Rotation tool window, with arrows for rotating the
              model or clipping plane.

       I      Open the Image overlay control dialog (only available when pro-
              gram is run as 3dmod).

       U      Open the Isosurface view dialog (only available when program is
              run as 3dmod).

       L      Open Object List dialog.

       m      Open Movie control dialog.

       M      Open Model editing dialog.

       N      Open Movie Sequence dialog.

       O      Open the Object editing dialog.

       V      Open the View editing dialog.

       Ctrl-S Snapshot image to TIFF file.

       Shift-S
              Snapshot image to file with primary non-TIFF format (selected by
              setting preferences in 3dmod; default is JPEG or PNG).

       Ctrl-Shift-S
              Snapshot image to file with second non-TIFF format.  This will
              be PNG if the primary format is not PNG, or JPEG if the primary
              one is PNG.

       z      Toggle the display of Z image planes in the model view (only
              available when program is run as 3dmod).

       s      Toggle Stereo On/Off.

       [ ]    Adjust parallax for stereo viewing.

       a      Invert the parallax angle.

       d      Toggle single/double buffering.

       Ctrl-Shift-V
              Toggle use of vertex buffer objects; can fix display artifacts
              when there are problems with graphics card or drivers.

       Ctrl-R Toggle low resolution drawing of mesh and spheres.

       p      Toggle drawing of a sphere at the current point position (only
              available when program is run as 3dmod).

       g G    Increase or decrease the quality (and time) of sphere drawing.

       c      Print clip plane information to standard output.

       Ctrl-C Toggle clipping plane on/off.

       o      Print model transformations to standard output.

       D      Delete the currently selected contour(s) if it was (or they
              were) selected with the third mouse button or with Ctrl-A.  Mul-
              tiple contours can be selected by holding the Ctrl key down
              while clicking with the third mouse button.

       Ctrl-A Select all contours in the current object that are being drawn;
              this excludes ones that are being clipped or turned off.

       Ctrl-Z Undo the last change to the model.  The list of actions that can
              be undone applies only to the current model and is cleared when
              switching between models.

       Ctrl-Y Redo a change that was undone.

       Use the online help for more information on using 3dmodv.

AUTHORS
       Jim Kremer
       David Mastronarde
       Quanren Xiong

SEE ALSO
       3dmod, imodinfo

BUGS
       Please email all bug reports to mast at colorado dot edu.



BL3DEMC                              4.7.3                           3dmodv(1)